It is currently Mon Feb 27, 2017 10:49 am

All times are UTC-05:00




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Help please
PostPosted: Fri Oct 28, 2016 11:40 pm 
Offline
n00b
n00b

Joined: Fri Oct 28, 2016 1:10 pm
Posts: 3
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Ok so I bought a 1987 Riva razz 50cc scooter off of a neighbor, he said it needed a new battery so I replaced it. But the electric start still will not work. All the lights and horn works. When I press the start button the oil light lights up. Anyone have any ideas. I'm typing this on my phone so I don't know how informative it is, need anymore details just ask I'll provide. I just need help please!

_________________
Proud owner of a 1987 red Riva Razz


Top
 Post subject: Re: Help please
PostPosted: Sat Oct 29, 2016 10:23 am 
Offline
n00b
n00b

Joined: Thu Oct 01, 2015 2:24 pm
Posts: 2
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Hello, you may have to either step on the rear brake pedal (or the rear brake lever - I'm not sure what you have) AND the scoot may have to be on the centerstand with any sidesatnd in the up position. Then try the starter button. It's the most simple thing I could think of that could be the problem. Don't ask me how I know. Colonel Stan


Top
 Post subject: Re: Help please
PostPosted: Sat Oct 29, 2016 12:24 pm 
Offline
n00b
n00b

Joined: Fri Oct 28, 2016 1:10 pm
Posts: 3
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
I went to try this and now the scooter acts like it has no battery no lights no horn nothing.

_________________
Proud owner of a 1987 red Riva Razz


Top
 Post subject: Re: Help please
PostPosted: Sun Oct 30, 2016 10:23 am 
Offline
n00b
n00b

Joined: Thu Oct 01, 2015 2:24 pm
Posts: 2
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
It's hard to diagnose from a distance, but here goes. You're going to have to start taking body parts off in order to get to the engine. If you can track down a manual it would be most helpful. From here it sounds like the starter may not be working ( a short in the stater or perhaps burned out?). If you remove the starter you cna test it by hooking it up to a 12 volt battery (single terminal on the starter body should be for the positive side of the battery). Hook up the negative to the body of the starter or touch the body of the starter to the negative side of the battery. The starter should spin right up. If it does not then the starter needs repair or replacement. If the starter does spin up then you either have an issue with the voltage getting to the starter or the motor may be frozen (thereby not allowing the starter to spin the motor). Let us know what you discover. Good Luck. Colonelstan


Top
 Post subject: Re: Help please
PostPosted: Tue Nov 01, 2016 3:49 pm 
Offline
Throttle Master
Throttle Master
User avatar

Joined: Tue Aug 28, 2012 5:01 pm
Posts: 535
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Location: Mississauga Ontario
does it want to start at all with the kick starter?

_________________
'01 & '02 Vino 2t, '13 KYMCO Movie 150


Top
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC-05:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited