2003 SR 50 scooter wont run properly

Modern Scoots from Vespa, Lambretta, Piaggio, Aprilia and Derbi
Post Reply
bomber baldy
n00b
n00b
Posts: 2
Joined: Sun Aug 27, 2017 2:33 am
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Contact:

2003 SR 50 scooter wont run properly

Post by bomber baldy »

my daughter has a 2003 SR Aprilia scooter and it cuts out whilst riding and is now blowing black smoke and flames out of the exhaust and runs really rough and is a pain to start
User avatar
GVH
Throttle Master
Throttle Master
Posts: 852
Joined: Sun Feb 01, 2009 10:08 am
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Location: Oakville, Ontario
Contact:

Re: 2003 SR 50 scooter wont run properly

Post by GVH »

Black exhaust usually means running to rich. To much fuel in the mix. If you have flames possibly ignition timing is way out ?? it would point to a bad CDI unit ? If the system is not firing at the right time fuel gets past into the exhaust system
Image
User avatar
GVH
Throttle Master
Throttle Master
Posts: 852
Joined: Sun Feb 01, 2009 10:08 am
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Location: Oakville, Ontario
Contact:

Re: 2003 SR 50 scooter wont run properly

Post by GVH »

Check the simple stuff first, is the sparkplug OK, sparkplug wiring, fouled carb flooding the cylinder ?

cdi units are not to pricy this ones about $42 delivered. Just make sure you get the right one for the scooter.

http://www.ebay.com/itm/Aprilia-SR-50-R ... QU&vxp=mtr
Image
kevinv710
Twist 'n Pro
Twist 'n Pro
Posts: 79
Joined: Tue Jan 14, 2014 3:55 am
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Contact:

Re: 2003 SR 50 scooter wont run properly

Post by kevinv710 »

sounds like piston, rings are toasted
Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests