Vino Issue

Salient/Riva 50, Beluga/ Riva 80, Razz, Jog, Vino, C3, BWs and Zuma scooters.
Post Reply
User avatar
tiny
Throttle Master
Throttle Master
Posts: 649
Joined: Tue Aug 28, 2012 5:01 pm
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Location: Mississauga Ontario
Contact:

Vino Issue

Post by tiny »

Okay here is the low down. Up until I replaced the old Rollers with new OEM (7grms) Rollers it was constantly hitting 69-70KPH on flat ground with a huge I'll call it turbo lag between 10-25KPH with the old worn rollers. They were so beat up and worn down that trying to get a proper reading on what they weighed was next to impossible weight readings were anywhere from 2-6gms.
Now it will still hit 70KPH till I stop for a light or corner and then it will not go past 40KPH.
What I replaced on it is the battery, OEM Rollers, a Gator Belt and new Stage Six exhaust. What is still on it when I got it is the after market Clutch Springs (which are red and really really stiff).

Any and all Ideas would be grateful guys.
Thanks
KYMCO ZX50 & Super9, '13 KYMCO Movie 150
User avatar
tiny
Throttle Master
Throttle Master
Posts: 649
Joined: Tue Aug 28, 2012 5:01 pm
To prevent spam, enter the year 'modern' scooters were first sold in North America (hint: 1982): 1982
Location: Mississauga Ontario
Contact:

Re: Vino Issue

Post by tiny »

Found the problem. The variatior that was in the Vino when I bought it was damaged by the old worn out rollers in it that when I replace the rollers they would get stuck in it.
So I bought a new variatior kit and with the new variatior in place of the old one it worked perfectly :D
KYMCO ZX50 & Super9, '13 KYMCO Movie 150
Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests